Hi everyone how’s your rooting going?

This forum is for anything related to the EVOKE model

Hi everyone how’s your rooting going?

Postby notafrog » February 6th, 2013, 11:06 pm

Mine not too well, since I haven't managed to get adb to talk to my evoke yet. :(
I've tried the PdaNet thingummy, tried using the driver in SDK extras, with the .inf file hacked to add the hardware keys:
USB\Vid_2207&Pid_0010&Rev_0222&M1_01
USB\Vid_2207&Pid_0010&M1_01

And still no response to "adb devices".
(Yes USB debug is connected.)

So come on now, what silly thing have I overlooked?
:?:

:D
notafrog
Junior Scroller
Junior Scroller
 
Posts: 10
Joined: February 3rd, 2013, 3:09 pm

Re: Hi everyone how’s your rooting going?

Postby Charlie » February 7th, 2013, 11:34 am

Hi,

It could be a few things, like you are missing the .Android folder and/or correct contents of the file in that folder (in windows, under current logged in user). Download the .zip below, put it on your desktop, unzip and then run the adbfix.bat - That should fix the .Android issues and if need be you can follow the instructions to uninstall the drivers you added and reinstall the ones within this .zip

ADB Fix
" Just because you could, doesn't mean you should. "
User avatar
Charlie
Trusted Developer
Trusted Developer
 
Posts: 2471
Joined: December 28th, 2010, 8:41 pm
Location: UK
Real Name: Charlie
Scroll Version: Moto G 16GB (4.4.2 rooted)
Nexus 7 - G1 (4.4.2 rooted)
Huawei Y300 (4.1.1 rooted - TWRP)
MK809 (4.1.1 rooted - CWM)
Raspberry Pi B (512MB)

Retired: Excel (CM10) & 1st Gen' (2.1) Tab'.

Re: Hi everyone how’s your rooting going?

Postby notafrog » February 7th, 2013, 1:54 pm

Thanks for the tip; I'll be trying it later soon as I get the chance.
notafrog
Junior Scroller
Junior Scroller
 
Posts: 10
Joined: February 3rd, 2013, 3:09 pm

Re: Hi everyone how’s your rooting going?

Postby notafrog » February 7th, 2013, 9:04 pm

Fantastico: adb worked first time and bin4ry's script did too. :mrgreen:

This is what was different between my attempt and the kit you posted:

1) The driver .dll files in the SDK I downloaded from google seem to be a more recent version (1009 instead of 1007 and around 40% bigger)

2) The following three lines in android_winusb.inf: I'd just blindly copied the values shown in Windows device management and omitted the third line completely:

; Scroll Evoke (comment line)
%SingleAdbInterface% = USB_Install, USB\VID_2207&PID_0010
%CompositeAdbInterface% = USB_Install, USB\VID_2207&PID_0010&MI_01
%SingleBootLoaderInterface% = USB_Install, USB\VID_2207&PID_0010

As far as the .android folder goes, it appeared to be already in order.

Thank you so much and I hope this helps anyone else who is struggling.
notafrog
Junior Scroller
Junior Scroller
 
Posts: 10
Joined: February 3rd, 2013, 3:09 pm

Re: Hi everyone how’s your rooting going?

Postby Spyder » February 8th, 2013, 3:41 pm

Hi Notafrog,
Being an inveterate tinkerer and a new-comer to Android I thought I would have attemped to 'root' my Evoke within days of buying it. However,so far I seem to be able to do everything I wanted to do with the Evoke in it's original shop state. I have Play Store access and most Apps appear to be working.
Can you give me a clue what I'm missing and how much better my life will be with a rooted Evoke?
Thanks
Spyder
Junior Scroller
Junior Scroller
 
Posts: 12
Joined: February 5th, 2013, 12:50 pm
Location: North West England
Real Name: Steve
Scroll Version: Scroll Evoke 4.1.1 (not rooted ... yet)

Re: Hi everyone how’s your rooting going?

Postby notafrog » February 10th, 2013, 10:24 pm

Well, since I'm a bit of a Linux veteran, I take offence at not having root access. It's instinctive I guess.

The immediate reason I wanted root was to use a DNS changing program and system-wide proxy settings.
These two help me get the foreign content (I'm English living in France) that I bought the device for in the first place. This also stops Google Play sending me to their French store, which I find extremely annoying.

I also installed Orbot, which is an Internet anonymizing system and requires root for access to the full feature set.

App Quarantine, which is just a nice UI for something you can do yourself from the Manage Apps menu, allows you to disable bundled apps. For me this is better than removing them completely because if you break something by doing so, you can easily re-enable it. I have achieved a significant slowdown in battery consumption by disabling apps that couldn't be disabled without rooting.

My next operation will be installing additional system fonts for use in certain apps.

And I'm sure I'll find more apps that need root as I go along. I'm actually brand new to tablets or even smartphones.
notafrog
Junior Scroller
Junior Scroller
 
Posts: 10
Joined: February 3rd, 2013, 3:09 pm

Re: Hi everyone how’s your rooting going?

Postby Rainbow » February 16th, 2013, 6:45 pm

Charlie wrote:Hi,

It could be a few things, like you are missing the .Android folder and/or correct contents of the file in that folder (in windows, under current logged in user). Download the .zip below, put it on your desktop, unzip and then run the adbfix.bat - That should fix the .Android issues and if need be you can follow the instructions to uninstall the drivers you added and reinstall the ones within this .zip

ADB Fix


Thanks for the zip - that did it (eventually!)

Couldn't get it to work initially, so I gave up for a couple of days, then I tried it again and then bingo, my laptop communicated fully with my evoke. No idea why - maybe I only needed a full restart - still it's done now, cheers
Rainbow
Scroll Apprentice
Scroll Apprentice
 
Posts: 30
Joined: February 11th, 2013, 10:31 pm
Scroll Version: Evoke with JB 4.1.1

Rooted

Re: Hi everyone how’s your rooting going?

Postby mange1984 » August 21st, 2013, 9:22 pm

I have scroll evoke anyone manage to root it yet cheers
mange1984
Junior Scroller
Junior Scroller
 
Posts: 20
Joined: August 21st, 2013, 12:58 pm
Location: wiltshire
Real Name: jonathan
Scroll Version: Scroll evoke 7 running jelly bean 4.1.1 scroll excel 2 ics 4.0.4 version blackberry playbook 16 gig blackberry bold 9790 touch

Re: Hi everyone how’s your rooting going?

Postby mange1984 » August 25th, 2013, 1:40 pm

Is there guide to rooting scroll evoke tried few times not getting far i feel im doing somethink wrong im new so lil help would ne appreciated if anyone has any spare time to help would be gratefull
mange1984
Junior Scroller
Junior Scroller
 
Posts: 20
Joined: August 21st, 2013, 12:58 pm
Location: wiltshire
Real Name: jonathan
Scroll Version: Scroll evoke 7 running jelly bean 4.1.1 scroll excel 2 ics 4.0.4 version blackberry playbook 16 gig blackberry bold 9790 touch


Return to Scroll EVOKE Forum - Scroll Evoke 7" Tablet

Who is online

Users browsing this forum: No registered users and 1 guest

cron